How can we help?

Table of Contents

Can’t connect Website, getting the “Invalid Request” error message!

If you are getting the “Invalid request” error upon failing to connect a Website to your MainWP Dashboard, it is more than likely that the OpenSSL library is not properly set on your MainWP Dashboard host. To begin the troubleshooting process, first, go to the MainWP > System > Server Information page and check the SSL Warning row. If it shows one of the following errors:

error:02001003:system library:fopen:No such process
error:02001002:system library:fopen:No such file or directory

it confirms that the problem is with the OpenSSL library. To solve this problem,

  1. Go to your MainWP Dashboard
  2. Go to the MainWP > Settings > MainWP Tools page and click the Quick Setup Wizard button
  3. When the setup starts, proceed to the first step and select Localhost > Windows. Even if you are not using Windows as the operating system, still select this option.
  4. The new option will appear where you can add the openssl.cnf file path (see here how to find the file). In some rare cases,  php.ini can show an incorrect file path for the openssl.cnf file, so it is best to simply run the Search feature on your computer and locate the file and get the precise location.
  5. Proceed to the next step and feel free to skip the rest of the Quick Setup wizard.

Once this process is completed, please check the Server Information again and verify that the SSL Warning is gone. If yes,  you can start connecting your child sites.

Still Have a Questions?
Search for additional solutions in the MainWP Community or start your own discussion